Archive

Posts Tagged ‘VS2008’

XAMAL intelisense broken after installing the Windows SDK for Windows Server 2008 and .NET Framework 3.5

March 5, 2009 6 comments

I recently faced to a wierd trouble with my VS  2008 environement. It was working perfectly well until the time I decide to install the SDK and SilverLight tool kit.
What happen is that any project with xamal was not able to open with intellisense in the designer. Instead I get a simple black and white text editor.

When you try to open such project you get the following error message :
The Microsoft.VisualStudio.Xaml ({E58C2A8B-BCC4-4559-AD59-D62EB6D58A22}) did not load because of previous errors. For assistance, contact the package vendor. To attempt to load this package again, type ‘devenv /resetskippkgs’ at the command prompt.

How to determine if  you are experiencing this issue

1.       Please review the article, Windows registry information for advanced users before using regedit.

2.       Using regedit, look at the key:  

·         On X86 machines: HKEY_CLASSES_ROOT\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

·         On X64 machines: HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{73B7DC00-F498-4ABD-AB79-D07AFD52F395}\InProcServer32

3.       If (Default) is empty you are experiencing this issue

For me I was not in that case but it was crashing anyway. So then I go to the next step which is :

 

  • Run from the command prompt with admin priviledge : devenv /setup (no help for me)
  • Run from the command prompt with admin priviledge : devenv /resetskippkgs (no help for me)

Then I have finally decide to try a repair of VS2008 and re-apply VS2008 SP1. After restarting VS2008 still no help

So as a last resort I retry to run the previous command from command prompt : devenv /resetskippkgs

And by magic, my problem get solved
For those who are still fighting you can try my steps if it helps

Good luck


Advertisements
Categories: Uncategorized Tags: